Login fails when using stored credentials

Dec 9, 2013 at 1:00 PM
When I try to login initially, the dialog comes up, I enter my credentials, it does whatever GIT command I requested.

When I try to run another command, or the same command over, I see the following error.

remote: Invalid username or password.
fatal: Authentication failed for 'my url'

Trying again, brings the dialog up again. Which kind of makes sense if it couldn't log in for some reason.

I've tried multiple repos. I haven't tried another user name, but have some suspicion that the problem is because my user name is an email and has an @ in it. Just a hunch though.
Dec 9, 2013 at 4:05 PM
I had the same problem with version 1.3. I unset gitcredentialstore from my Git global config and installed version 1.2 and the problem went away.
Jan 8, 2014 at 9:40 PM
I had the same issue. It turned out that credentials were getting removed from Credentials Manager during the second login attempt. Rolling back to 1.2 fixed the issue.
Jan 24, 2014 at 6:26 AM
Edited Jan 27, 2014 at 9:30 PM
I had this issue too, but it took a long time to realise I was running 1.3 since I installed it from http://chocolatey.org/packages/git-credential-winstore which is currently still using 1.3.
Mar 12, 2014 at 7:10 PM
Same issue, and all machines have this issue too.